超级研报群 - 设为首页 - 加入收藏 - 网站地图 股似海(Www.Gusihai.com) 股票学习网!
当前位置:主页 > 指标公式 > 钱龙软件指标 > 正文

钱龙软件指标公式源码

时间:2020-05-25 18:16 来源:股似海学习网 作者:股似海学习网 阅读:
软件类型:国产软件 授权方式:共享软件 界面语言:简体中文 软件大小:未知 文件类型:其它 运行环境:Win2003,WinXP,Win2000,Win9X 软件等级:★★★☆☆ 发布时间:2020-05-25 插件情况:无插件,请放心使用。 下载次数:
内容介绍:
钱龙软件指标公式源码

原理解析:
VZF赋值:(成交量(手)-1日前的成交量(手))/1日前的成交量(手)的L2日简单移动平均
赋值:(收盘价-收盘价的L3日简单移动平均)/收盘价的L3日简单移动平均*100
输出MY:BIAS3*(1+VZF)
输出钱龙短线:MY,COLORSTICK
钱龙短线的N日简单移动平均,画黄色
输出钱龙布林N 1 100 20D 1.01 5 2MB:收盘价的N日简单移动平均
R赋值:(收盘价-MB)的2乘幂
X1赋值:R的N日简单移动平均
X赋值:X1的开方
输出UPPER:MB+D*X
输出LOWER:MB-D*X
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为5,1不为0则画空心柱.,画红色
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,画绿色
当满足条件收盘价>=开盘价时,在收盘价和最高价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,画红色
当满足条件收盘价>=开盘价时,在开盘价和最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,画红色
当满足条件收阴线时,在收盘价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画绿色
当满足条件收阴线时,在开盘价和最高价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画绿色
输出LONG乾龙长线N 1 100 10乾龙长线:0
VAR1赋值:1日前的收盘价
VAR2赋值:成交量(手)的2日累和/((2日内最高价的最高值-2日内最低价的最低值)*100)
VAR3赋值:(收盘价-VAR1)*VAR2
VAR4赋值:VAR3的历史累和
VAR5赋值:VAR4的10日[1日权重]移动平均
VAR6赋值:VAR4的20日[1日权重]移动平均
输出LONMA: VAR5-VAR6的N日简单移动平均画绿色
VAR5-VAR6,画黄色
输出VAR5-VAR6,COLORSTICK钱龙EXPMAEXPMA1 : (收盘价-1日前的收盘价的N1日指数移动平均)*2/(N1+1)+1日前的收盘价的N1日指数移动平均
输出EXPMA2 : (收盘价-1日前的收盘价的N2日指数移动平均)*2/(N2+1)+1日前的收盘价的N2日指数移动平均
当满足条件收阳线时,在开盘价和收盘价位置之间画柱状线,宽度为6,1不为0则画空心柱., , 画红色
当满足条件平盘时,在开盘价和收盘价位置之间画柱状线,宽度为6,1不为0则画空心柱., , 画红色
当满足条件收阳线时,在最低价和开盘价位置之间画柱状线,宽度为0.8,1不为0则画空心柱., , 画红色
当满足条件平盘时,在最低价和开盘价位置之间画柱状线,宽度为0.8,1不为0则画空心柱., , 画红色
当满足条件收阳线时,在收盘价和最高价位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,,画红色
当满足条件平盘时,在收盘价和最高价位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,,画红色
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱., , 画青色
当满足条件收阴线时,在最低价和最高价位置之间画柱状线,宽度为0.8,0不为0则画空心柱., , 画青色
终极指标TH赋值:最高价和1日前的收盘价的较大值
TL赋值:最低价和1日前的收盘价的较小值
ACC1赋值:收盘价-TL的7日累和/TH-TL的7日累和
ACC2赋值:收盘价-TL的60日累和/TH-TL的60日累和
ACC3赋值:收盘价-TL的28日累和/TH-TL的28日累和
输出终极指标:(ACC1*60*28+ACC2*7*28+ACC3*7*60)*100/(7*60+7*28+60*28)
70,画黄色
50,画洋红色
35,画绿色
压缩K线HSL赋值:(成交量(手)/成交量(手)的55日简单移动平均)
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为换手线*10,1不为0则画空心柱.,画红色
当满足条件收阳线时,在最高价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画红色
当满足条件收阳线时,在开盘价和最低价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为换手线*10,0不为0则画空心柱.,画白色
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画白色
当满足条件收盘价=OPENANDC>1日前的收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为换手线*10,1不为0则画空心柱.,画红色
当满足条件收盘价=OPENANDC>1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
当满足条件收盘价=OPENANDC<1日前的收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为换手线*10,1不为0则画空心柱.,画白色

当满足条件收盘价=OPENANDC<1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,,画白色

当满足条件平盘时,在最高价和最低价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,,画白色
当满足条件平盘时,在收盘价和开盘价位置之间画柱状线,宽度为换手线*10,0不为0则画空心柱.,,画白色
输出钱龙DPO(区间振荡线)区间震荡线:收盘价 - 11日前的收盘价的20日简单移动平均
MB赋值:DPO的20日简单移动平均
R赋值:(DPO-MB)*(DPO-MB)
X赋值:R的20日简单移动平均的开方
MB+1.96*X
鸬雌鱒AR1赋值:1日前的收盘价
VAR2赋值:成交量(手)的2日累和/((2日内最高价的最高值-2日内最低价的最低值)*100)
VAR3赋值:(收盘价-VAR1)*VAR2
VAR4赋值:VAR3的历史累和
VAR5赋值:VAR4的5日[1日权重]移动平均
VAR6赋值:VAR4的8日[1日权重]移动平均
输出变动速率线: VAR5-VAR6
输出OSCMA: OSC的4日简单移动平均
OSC, COLORSTICK
输出VD: 如果OSC>0,返回OSC*1.003,否则返回OSC*1.003>0的34日累和/34
输出VE: 如果OSC<=0,返回OSC*0.97,否则返回OSC*0.97<0的34日累和/34,
0
钱龙地量线A赋值:成交量(手)*收盘价/1000
输出B:A的9日简单移动平均,画黄色
当满足条件B时,在0和B位置之间画柱状线,宽度为1.2,0不为0则画空心柱.
输出平均地量线:0日内B的最低值,画红色,线宽为2
输出相对地量线:500日内B的最低值,画蓝色,线宽为2
输出钱龙量布林MB:成交量(手)的13日简单移动平均
R赋值:(成交量(手)-MB)的2乘幂
X1赋值:R的13日简单移动平均
X赋值:X1的开方
输出UPPER:MB+1*X
输出LOWER:MB-1*X
钱龙慢威廉RSV赋值: (9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100
输出LWR1:RSV的3日[1日权重]移动平均
曲腰量VAR1赋值:成交额(元)/10000000
输出量能:VAR1/VAR1的5日简单移动平均 COLOR999999,POINTDOT
VAR2赋值:如果收盘价>=1日前的收盘价,返回VAR1,否则返回VAR1的相反数
VAR3赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
VAR4赋值:VAR3*36
VAR5赋值:VAR4-VAR2
输出曲腰量:VAR5的Q日累和的Q1日指数移动平均 画白色
输出MA1:曲腰量的Q2日指数移动平均,COLORSTICK
当满足条件曲腰量>=MA1时,在MA1和曲腰量位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
输出变动速率INPUT:N(13,1,100),M(6,1,50)
输出R:(收盘价-N日前的收盘价)/N日前的收盘价*100
输出RMA:R的M日简单移动平均
输出D:如果R<0,返回-R,否则返回R
0,LINEDOT
<!--{cke_protected}{C}%3C!%2D%2D%2B%2B%20PLUGIN_CODE%20QCOMIC%20BEGIN%2D%2D%3E--><!--{cke_protected}{C}%3C!%2D%2D%2B%2B%20PLUGIN_CODE%20QCOMIC%20END%2D%2D%3E-->


钱龙软件指标公式源码

源码:

L3 1 300 5
L2 1 300 5
N 1 50 10


vZF:=ma((v-ref(v,1))/ref(v,1),l2);
BIAS3 :=(CLOSE-MA(CLOSE,L3))/MA(CLOSE,L3)*100;
{BIAS3:=MA((C-REF(C,1))/REF(C,1)*100,10);}
my:bias3*(1+vZF);
钱龙短线:my,colorstick;
ma(钱龙短线,n),coloryellow;

钱龙布林
N 1 100 20
D 1.01 5 2
mb:ma(c,n);
r:=pow((c-mb),2);
x1:=ma(r,n);
x:=SQRT(x1);
upper:mb+d*x;
lower:mb-d*x;
STICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),colorgreen;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorgreen;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),colorgreen;


LONG
乾龙长线
N 1 100 10
乾龙长线:0;
Var1:=REF(CLOSE,1);
Var2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
Var3:=(CLOSE-Var1)*Var2;
Var4:=SUM(Var3,0);
Var5:=SMA(Var4,10,1);
Var6:=SMA(Var4,20,1);
LONMA: MA(Var5-Var6,n)COLORgreen;
Var5-Var6,COLORyellow;
Var5-Var6,COLORSTICK



钱龙EXPMA
{n1=5 100 12 n2=5 100 50}
EXPMA1 : (CLOSE-REF(EMA(CLOSE,N1),1))*2/(N1+1)+REF(EMA(CLOSE,N1),1);
EXPMA2 : (CLOSE-REF(EMA(CLOSE,N2),1))*2/(N2+1)+REF(EMA(CLOSE,N2),1);
STICKLINE(CLOSE>OPEN,OPEN,CLOSE,6,1), , COLORRED;
STICKLINE(CLOSE=OPEN,OPEN,CLOSE,6,1), , COLORRED;
STICKLINE(CLOSE>OPEN,LOW,OPEN,0.8,1), , COLORRED;
STICKLINE(CLOSE=OPEN,LOW,OPEN,0.8,1), , COLORRED;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.8,1),,COLORRED;
STICKLINE(CLOSE=OPEN,CLOSE,HIGH,0.8,1),,COLORRED;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,6,0), , COLORCYAN;
STICKLINE(CLOSE<OPEN,LOW,HIGH,0.8,0), , COLORCYAN;



终极指标
TH:=MAX(HIGH,REF(CLOSE,1));
TL:=MIN(LOW,REF(CLOSE,1));
ACC1:=SUM(CLOSE-TL,7)/SUM(TH-TL,7);
ACC2:=SUM(CLOSE-TL,60)/SUM(TH-TL,60);
ACC3:=SUM(CLOSE-TL,28)/SUM(TH-TL,28);
UOS:(ACC1*60*28+ACC2*7*28+ACC3*7*60)*100/(7*60+7*28+60*28);
70,COLORYELLOW;
50,COLORMAGENTA;
35,COLORGREEN;



压缩K线
hsl:=(v/ma(vol,55));
STICKLINE( c>open,c,o,hsl*10 ,1),COLORRED;
STICKLINE( c>open,h,c,0.5 ,0),COLORRED;
STICKLINE( c>open,o,l,0.1 ,0),COLORRED;
STICKLINE( c<open,c,o,hsl*10 ,0),COLORWHITE;
STICKLINE( c<open,h,l,0.1 ,0),COLORWHITE;
STICKLINE( c=open and c>ref(c,1),c,o,hsl*10 ,1),COLORRED;
STICKLINE( c=open and c>ref(c,1),h,l,0.1,0),COLORRED;
STICKLINE( c=open and c<ref(c,1),c,o,hsl*10 ,1),COLORWHITE;;
STICKLINE( c=open and c<ref(c,1),h,l,0.1,0),,COLORWHITE;;
STICKLINE( c=open ,h,l,0.1,0),,COLORWHITE;
STICKLINE( c=open ,c,o,hsl*10,0),,COLORWHITE;



钱龙DPO(区间振荡线)

dpo:C - REF(MA(CLOSE,20),11);
mb:=ma(dpo,20);
r:=(dpo-mb)*(dpo-mb);
x:=SQRT(ma(r,20));
mb+1.96*x;
mb-1.96*x


钱龙OSC
艾略特震荡器
Var1:=REF(CLOSE,1);
Var2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
Var3:=(CLOSE-Var1)*Var2;
Var4:=SUM(Var3,0);
Var5:=SMA(Var4,5,1);
Var6:=SMA(Var4,8,1);
OSC: Var5-Var6;
OSCMA: MA(OSC,4);
OSC, COLORSTICK;
VD: SUM(IF(OSC>0,OSC*1.003,OSC*1.003>0),34)/34;
VE: SUM(IF(OSC<=0,OSC*0.97,OSC*0.97<0),34)/34, ;
0;



钱龙地量线
a:=v*c/1000;
b:ma(a,9),COLORYELLOW;
STICKLINE(b,0,b,1.2,0);
平均地量线:llv(b,0),colorred,LINETHICK2;
相对地量线:llv(b,500),COLORBLUE,LINETHICK2;


钱龙量布林
mb:ma(v,13);
r:=pow((v-mb),2);
x1:=ma(r,13);
x:=SQRT(x1);
upper:mb+1*x;
lower:mb-1*x;



钱龙慢威廉
RSV:= (HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100;
LWR1:SMA(RSV,3,1);
LWR2:SMA(LWR1,3,1)




曲腰量
{Q(5,1,20)Q1(3,1,10)Q2(3,1,10)}
var1:=AMOUNT/10000000;
量能:var1/ma(var1,5) COLOR999999,POINTDOT;
var2:=if(c>=ref(c,1),var1,REVERSE(var1));
var3:=(c-ref(c,1))/ref(c,1)*100;
var4:=var3*36;
var5:=var4-var2;
曲腰量:EMA(SUM(var5,q),q1) COLORWHITE;
ma1:ema(曲腰量,q2),COLORSTICK;
STICKLINE(曲腰量>=ma1 ,ma1,曲腰量 ,2 ,0 ),COLORYELLOW;



变动速率

INPUT:N(13,1,100),M(6,1,50);
R:(C-REF(C,N))/REF(C,N)*100;
RMA:MA(R,M);
d:if(R<0,-R,R);
0,LINEDOT;<!--++ plugin_code qcomic begin--><!--++ plugin_code qcomic end-->
顶一下
(0)
0%
踩一下
(1)
100%
下载地址:
注意事项:
1.股似海-股票学习网站上资源如需解压密码的请输入本站域名:www.gusihai.com 请仔细输入!复制无效!
2.如果这个资源总是不能下载的请点击报告错误,谢谢反馈!! 站长微信:gsh2028 资料反馈、查找
3.下载本站资源,如果服务器暂不能下载请过一段时间重试!
4.如果遇到什么问题,请到本站论坛去咨寻,我们将在那里提供更多 、更好的资源!
5.本站为非盈利性质的学术交流网站,网站资源仅供教学、研究使用,请下载后24小时内自行删除。如用于商业用途,请购买正版。
上一篇:没有了
下一篇:某著名软件的能量型指标CR真正原版指标
推荐内容
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。