超级研报群 - 设为首页 - 加入收藏 - 网站地图 股似海(Www.Gusihai.com) 股票学习网!
当前位置:主页 > 指标公式 > 指标编写答疑 > 正文

提示交易天数的公式

时间:2019-08-27 12:12 来源:股似海学习网 作者:股似海 阅读:
编写要求:
请老师写个公式
通达信软件
设想:最新一天的交易日,K线图,K线下方显示为1(如图)
往后数,顺序依次为:1,5,10,20,30,60,120,240,显示周期为任意周期!!

解答如下:
如果一定要历史信号,这样
A:=REF(C,BARSLAST(CURRBARSCOUNT=10));
B:=CURRBARSCOUNT=5 AND C/A>=0.99 AND C/A<=1.01;
DRAWICON(B,L*0.99,11);
DRAWNUMBER(CURRBARSCOUNT<=20,L,CURRBARSCOUNT),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=10,L,CURRBARSCOUNT),COLORMAGENTA;
DRAWNUMBER(CURRBARSCOUNT=5,L,CURRBARSCOUNT),COLORMAGENTA;
D:=BARSLAST(MOD(CURRBARSCOUNT,5)=0);
E:=C/REF(REF(C,D),1)*100-100;
F:=ABS(E)<=1 AND D=0 AND CURRBARSCOUNT>=10;
DRAWICON(F,L*0.99,11);
提示交易天数的公式

声明:以上内容仅供参考,不构成任何投资建议,股市有风险,投资需谨慎!

(责任编辑:股似海学习网)

顶一下
(0)
0%
踩一下
(0)
0%
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。